
 

 

 

LIBERTY™ 
MAPPING 

 

 

 

 

 

LIBERTY™ 
MAPPING 
TOOLKIT 

 

 

 

 

 

URM04PH171 – REV. C 
FEBRUARY 2008 

 

 



  LIBERTY MAPPING TOOLKIT 

 

Copyright © 2004, 2005 by Alken, Inc., dba Polhemus 
Colchester, Vermont, U.S.A. 

All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, 
or transmitted, in any form or by any means, mechanical, photocopying, recording or otherwise, 
without the prior written permission of Polhemus. No patent liability is assumed with respect to 
the use of the information contained herein. While every precaution has been taken in the 
preparation of this manual, Polhemus assumes no responsibility for errors or omissions. Neither 
is any liability assumed for damages resulting from use of the information contained herein. 

3SPACE® is a registered trademark of Polhemus; LIBERTY™ and QWIK-MAP™ are 
trademarks of Polhemus. 

 

CUSTOMER SERVICE 
If problems are encountered with the LIBERTY Mapping Toolkit, or if you are having difficulty 
understanding how the product works, help is just a telephone call away.  

Call Polhemus at the numbers listed below and select “2” for Customer Service and then “1” for 
Technical Support. Polhemus is open Monday through Friday, 8:00 AM to 5:00 PM, Eastern 
Standard Time. For the most part, our customer service representatives are usually able to solve 
problems over the telephone and get you back into the fast lane right away.  

Help also is available on our web page at www.polhemus.com. Simply double-click Technical 
Support, and then click techsupport@polhemus.com to send us an email describing the problem 
or question.  

 

 
 

Polhemus 
40 Hercules Drive 

PO Box 560 
Colchester, VT 05446 

 
From within the U.S. and Canada: (800) 357-4777 
From outside the U.S. or Canada: (802) 655-3159 

Fax #:(802) 655-1439 
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1. Introduction to Compensation Mapping 
Distortion is generated by highly conductive metals in the area of intended use. The Polhemus 
mapping process can be utilized to significantly reduce these distortions in most areas. The 
mapping process generally reduces the distortion errors by a factor of 25 or more. Since the 
errors can never be completely eliminated, best performance can be obtained by initially 
minimizing these distortions before mapping, then invoking mapping to reduce the residual 
errors. 

Minimizing the distortion is done by selecting an installation site that is generally free of, or as 
far away as possible from, large metal objects such as file cabinets, desks, air conditioning duct 
work and the like. If the intended use of the tracking system is to operate over a large volume 
(using the Long Ranger® Source), note that most industrial floors and walls have internal steel 
reinforcement. In these cases a nonmetal stage or riser (constructed of 2x4’s or the like and 
plywood; standard nails or screws can be used), may be required if operation to the stage/riser 
floor is desired. Stage heights of only four (4) inches seem to provide enough floor separation for 
most applications if the Long Ranger is being utilized. If the 2” or 4” Source is being used, more 
separation (a higher riser or stage) is required. 

Moderate distortion of a magnetic field can be corrected through the use of Polhemus’ mapping 
procedure. The basics of compensation mapping, also known as calibration, are simple. First 
create a mapping fixture where sensors are placed in known and fixed positions. Move this 
fixture to known locations in the environment. Compare the position and orientation (P&O) 
readings from the tracker to the known P&O readings of the fixture. This data is then used by the 
Polhemus PC Windows®-based mapping software to compute a correction algorithm that is 
loaded into the LIBERTY tracker. 

There are two ways to develop a compensation map with the LIBERTY system. For small 
volumes (typically covered by a 2-inch source) the Polhemus QWIK-MAP fixture can be used. 
For larger volumes, (those covered by a Long Ranger or 4-inch source), a user-created custom 
mapping fixture can be used. 

The unique difference between this mapping method and previous mapping methods used by 
Polhemus is that the origin and coordinate system is not referenced to the magnetic source 
position. The user defines the origin and coordinate system (see MapCollect Application on page 
22). 

In this document Ten Simple Steps to a LIBERTY Map: Using the Polhemus QWIK-MAP (see 
page 3) are given for compensating a small region, should the user choose to purchase a QWIK-
MAP fixture. If a larger volume is needed, the same software package guides the user through 
the use of a custom mapping fixture. 

The basic procedure for creating a map consists of the following steps: 

1. Create a LIBERTY definition file (*.ldf). This file defines the configuration of the 
mapping fixture. For the QWIK-MAP fixture this is predefined. If a custom mapping 
fixture is being used, an *.ldf file is created using the DefineFrame Application, page 15 
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2. Securely place magnetic source in the desired location (the source must not move after 
mapping or a new map will be needed). 

3. Collect data, then create the map using the Polhemus MapCollect Application on page 
22. 

4. Load map into the LIBERTY tracker and enable map. 
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Ten Simple Steps to a LIBERTY Map: Using the Polhemus QWIK-MAP 

1. Assemble Polhemus QWIK-MAP.  See Setting up the QWIK-MAP Fixture on page 4. 
QWIK-MAP is designed to use four sensors. Customer-created custom mappers 
utilizing a special branch of the mapping software can use 4 to 16 sensors. 

IMPORTANT 

The floor grid must be a minimum of four points along each axis.  
Fewer points than this can cause faulty maps. 

2. Secure QWIK-MAP fixture to base of area to be mapped. 
3. Determine the location for source and secure (as far as practical from large metal objects, 

yet as close as possible to the area of operation). 
4. Attach LIBERTY to Host PC via USB or RS232 (COM 1, 115,200 baud, no parity, no 

handshaking) and power up. 

5. Select the File->Use Polhemus QWIK-MAP Definitions menu item or select the  
button on the main toolbar. See QWIK-MAP Setup, on page 10. 

6. Set the directions for the three axes in the Set Axis Direction for QWIK-MAP dialog box. 
See QWIK-MAP Setup on page 10. 

7. Place application in collection mode by selecting the Collection->Collect Data menu 
item or the  toolbar button. See Data Collection on page 11. 

8. Place the mapper pole in the designated position and press the Enter key.  Repeat for each 
point in the fixture. Be sure to fully insert the mapping pole at each position. 

9. Create a map by selecting the Data->Create Map menu item or the  toolbar item.  
Specify a filename and ID for the new map being created. See Map Creation on page 12. 

10. Load the map into LIBERTY by selecting the Data->Load Map menu item or the  
toolbar item and selecting the map filename created in the previous step.  Choose the map 
location where the map is to be loaded. See Map Loading on page 12. 

After the map has been created and loaded, compensation is turned on by using the 
D<map number><enter> command, where “map number” is the location specified in step 
10.  Use D0<enter> to turn compensation off. Compensation may also be turned on or off 
through the corresponding API calls in the SDK. 

For a more detailed description of using the QWIK-MAP fixture, the MapCollect Software, 
or creating maps without the QWIK-MAP, see the following documentation. 

NOTE:  The QWIK-MAP fixture is intended to correct moderate distortion errors to the 1° 
and ¼-inch class of accuracy.  Higher accuracies are achievable with precision mapping 
fixtures. 
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1.1 Setting up the QWIK-MAP Fixture 

The Polhemus QWIK-MAP fixture is shown in Figure 1. 

 
Figure 1  QWIK-MAP Setup 

This fixture can be purchased from Polhemus as a low-cost relaxed-accuracy mapping fixture. It 
allows the user to quickly and easily map an 18 in. x 18 in. x 18 in. (46 cm x 46 cm x 46 cm) 
volume using four sensors. It is intended to correct gross distortion errors to the 1° and ¼  in. 
(.3 cm) class of accuracy. Higher accuracies are achievable with precision mapping fixtures. The 
QWIK-MAP has a predefined configuration (*.ldf) file that is delivered with the mapping 
software. It is important to set the sensors on the pole of the QWIK-MAP fixture correctly so the 
sensor placement corresponds to the configuration file. The following illustrations show the 
proper way of placing the sensors in the mapping pole. 

Open up the pole triangle and firmly insert sensors in cutouts as shown in Figure 2 and  Figure 
3. Thread cables through round cutout as shown. 

   
Figure 2  Placing Sensors in the QWIK-MAP pole  Figure 3  Sensors placed in the QWIK-MAP pole 

 

It is important that the sensors are firmly inserted into the fixture exactly as shown. Note that 
Sensor 1 is facing in the opposite direction from the other three sensors.   
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The next step is to fold the pole back into its triangle shape as shown in Figure 4 and Figure 5. 
Secure with hook and loop tape provided in the QWIK-MAP kit. 

   
Figure 4  Folding the QWIK-MAP triangle pole Figure 5  QWIK-MAP pole folded to its original position 

Finally, insert the triangular pole fully into the base as shown in Figure 6. You are now ready to 
proceed to the MapCollect Application section of this document. 

 
Figure 6  Inserting the QWIK-MAP pole into the base 
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1.2 Setting up a Custom Mapping Fixture 

A custom mapping fixture can be used in lieu of the QWIK-MAP fixture. A custom fixture can 
use anywhere from 4 to 16 sensors. An example of a mapping pole fixture is shown in Figure 7. 
The sensors do not have to be evenly spaced or in the same orientation. They only have to be 
known and stay in a fixed position. It is essential that the fixture be constructed of non-
conductive (not just non-magnetic) material; e.g., do not use aluminum, except for fasteners (e.g. 
nails or screws). After the fixture is configured, a definition file *.ldf for the fixture must be 
created, as explained in the DefineFrame Application section. After the *.ldf is created the 
mapping process can proceed, as detailed in the MapCollect Application section. 

IMPORTANT 
The floor grid must be a minimum of four points along each axis.  

Fewer points than this can cause faulty maps. 

1.2.1 Constructing the Mapping Pole 
Mapping poles can be constructed using a straight, flat-sided wooden pole or board (such as a 
2x4), available from any lumber supplier (see Figure 7.)  

 
Figure 7  Sample Mapping Pole 
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The wooden pole is then mounted and braced to the corner of a base plate board, such as an 18” 
square of plywood; refer to Figure 8. 

 
Figure 8  Bracing the Mounting Pole 

The pole should be braced so as to be vertical at all times as the fixture is moved about the space 
to be mapped. A mapping pole can easily be assembled in a half hour or so. 

1.2.2 Mounting the Sensor Clips 
Affix self-adhesive sensor clips to the wooden pole at regular spacing (such as 13” apart); see 
Figure 9. (Polhemus can supply a kit of self-adhesive sensor clips to hold the sensors in place on 
the pole to aid in this process.) Carefully align the edge of the clips with the edge of the wooden 
pole. Eight sensors would cover about 8 feet of pole length.  

 
Figure 9  Positioning Sensor clips 
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The sensors can then be clipped onto the pole in sequence, starting with sensor 1 in the lowest 
position. Carefully mount each sensor clip as shown in Figure 10.  

 
Figure 10  Mounting the Sensor clips 

1.2.3 Affixing the Sensors 
Be precise in the seating of the sensors, placing them so that consistent rotation is achieved; see 
Figure 11. (For example, set all sensors straight into the clip.) The rear edge of the sensor must 
be seated snugly at the base of the clip. 

 

 
Figure 11  Proper Sensor mounting in self-adhesive clip 
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Route the sensor cable through the cable clip (as shown in Figure 12) so as to restrain the cable 
from moving the sensor head as the pole is moved throughout the space to be mapped. 

 
Figure 12  Routing Sensor cable through clips 

Construction of the mapping pole is then complete. 

 
Figure 13  Mapping Pole braced, with Sensors attached 

1.2.4 Marking A Reference Grid 
A reference grid should be made on the floor (or base of the riser, if one is being used); tape or a 
chalk line can be used. Normally a 12-inch grid is used. Alternately, the intersections of floor 
tiles could be useful. In the mapping process the pole is moved and aligned to each grid point, 
and data from all sensors is taken at each pole location see Floor Grid Definition on page 17 for 
further instructions. Each location takes about 12-15 seconds to map, so a 10 foot x 10 foot area 
could be mapped in about ½ hour once the pole and grid are constructed. 
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1.3 Procedure to Create and Load a Map 

1.3.1 Preparation 
The first step in creating a map is to define the area to be mapped. Here are some questions to 
ask: 

• How big of an area needs to be mapped? 

• Can I use the QWIK-MAP or is a custom mapper needed? 

• How many sensors are needed on the pole? 

• How far apart do the grid points need to be? 

• Where should the origin be placed? 

• Are there specific axis configuration requirements (should X be pointing a specific way)? 

• Where will the source be located? 

• How much distortion correction is needed? 

Keep in mind that the largest motion volume for the QWIK-MAP is 18 in. H x 18 in. W x 
18 in. D. 

If you will not be using the QWIK-MAP you will be required to create a custom *.lmd file using 
the DefineFrame utility (DefineFrame.exe) that shipped with this package. 

1.3.2 QWIK-MAP Setup 
The user should keep in mind that the QWIK-MAP fixture is intended to correct distortion errors 
to the 1° and ¼ inch class of accuracy. Higher accuracies are achievable with precision mapping 
fixtures. Before collecting data the user must inform the MapCollect Application that the QWIK-
MAP fixture is to be used. This is done by selecting the File->Use Polhemus QWIK-MAP 
Definitions menu item or selecting the  button on the main toolbar. When the QWIK-MAP 
option is selected the application will query the user for the direction of each axis. The QWIK-
MAP fixture has three axes labeled Axis 1, Axis 2, and Axis 3. The user must identify which of 
these axes correspond to the X, Y, and Z axes respectively. This is done by entering the data into 
the Set Axis Directions for QWIK-MAP dialog box shown in  Figure 14. 

 
Figure 14  Set Axis Directions window 
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Keep in mind, when selecting the vertical axis, that axis 3 is pointing down, in the opposite 
direction from the QWIK-MAP sensor pole. The three axes must comprise a right-hand 
coordinate system. 

Make sure the QWIK-MAP fixture is taped or otherwise secured or stabilized to a non-metal 
base so the fixture can not move while data are being collected. 

1.3.3 Custom Map Setup 
If the user is not using the QWIK-MAP, then a custom *.lmd file must be created using the 
DefineFrame Application shipped with this package (see Section 2, on page 15). All pole and 
grid definitions are contained in the *.lmd file. The user informs the MapCollect application that 
a custom *.lmd file is to be used by selecting the File->Set Definition File menu item or the 

button on the main toolbar. This will allow the user to navigate to the *.lmd file that should be 
used in the upcoming mapping session. 

1.3.4 Data Collection 
Before starting to collect data the source must be installed in a fixed location. Any location 
within specified distances to the mapped area is fine. The orientation of the source also is not 
important. However, once the data has been collected, the source may not be moved. Once a 
source has been moved, any maps previously created will no longer be valid. In other words, if 
multiple environments need to be used, consider purchasing a source for each one. 

Finally, LIBERTY should be set up and all sensors and the source connected. LIBERTY should 
be connected to the host PC by RS232 in COM Port 1 at a baud rate of 115,200, or via USB 
connection. Turn on LIBERTY. Other COM Ports may be specified in the Collection->Set COM 
Port menu item. 

The user should decide whether to use the High Distortion Mode or the Low Distortion Mode. 
This mode is set in the Collection Menu. The High Distortion Mode is valuable if the mapped 
area exhibits areas of very high distortion, but in areas of less distortion may create very noisy 
data. The High Distortion Mode is only available if the user has connected a “distortion 
mitigation technology (DMT)” source to the tracker. The user may have to try both modes in 
order to determine which will provide the better results. The default setting is High Distortion 
Mode but if a DMT source is not detected the mode will automatically be set to the Low 
Distortion Mode. 

At this point data collection can begin. When the user selects the Collection->Collect Data menu 
item or the  toolbar button, LIBERTY will be placed into data collection mode and the data 
collection toolbar will be visible. (If the application cannot connect with LIBERTY, the 
application will show an error and remain in normal mode.) If a DMT source is being used and 
the High Distortion Mode has been set in the Collection->High Distortion Mode menu item, the 
user will be asked to move the sensor pole to a specific position for an additional calibration step. 
Once the data collection toolbar is visible, the user should move the sensor pole to the first grid 
point as indicated in the grid view. There are four different ways to direct the application to take 
data at the selected grid point: 
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1. Select the Collection->Take Point menu item. 

2. Select the  item on the Data Collection toolbar. 

3. Press the Enter key. 

4. Double-click the mouse on the point to be collected. 

The first three of these options will cause the application to select the next uncollected point after 
the data have been taken. Double-clicking the mouse on a point will collect the data at that point 
but will not change the point selection. Utilizing the Enter key can permit the data collection to 
move rapidly. If data are taken at the wrong point or the user wishes to re-take data at a particular 
point for any reason, that point may be selected with the mouse and the data re-taken in the same 
manner it was originally taken. If it is desired to erase one or more points the user can 
accomplish this by selecting the Collection->Clear Point or Clear All Points menu items or the 

 or  toolbar items respectively. When all grid points have been collected a LIBERTY map 
can be created. 

1.3.5 Map Creation 
When all the data have been collected the user can create a LIBERTY map by selecting the 
Data->Create Map menu item or the  toolbar item. The application will then query the user 
for a file name in which to store the map. This file will have a *.lmf extension and is used to load 
maps into LIBERTY systems. When the user has specified a file, the application will ask the user 
to provide a map ID for this map. The map ID is how LIBERTY will identify the map to the 
user. Since a LIBERTY can store up to three maps, the ID is a convenient way for the user to 
distinguish between the maps. This ID should be less than 16 characters and should have some 
significance to the LIBERTY user. After the map ID has been provided, the application will use 
the collected data to create the LIBERTY map with the provided ID, and store it in the specified 
*.lmf file. 

1.3.6 Map Loading 
Once the map is created, the next step would be to load the map into LIBERTY. However, the 
map to be loaded need not be the map just created. The MapCollect application will load any 
*.lmf file that the user specifies. To initiate map loading, the user should select the Data->Load 
Map menu item or the  toolbar item. The application will then query the user for the *.lmf file 
to be loaded. Once the *.lmf file is selected the application will query LIBERTY for existing 
maps and present the user with a choice of locations to store the map in LIBERTY. LIBERTY 
has three “positions” for storing maps. Positions may not be skipped, but maps may be 
overwritten. For example, if LIBERTY has a map stored in Position 1, and another map is to be 
loaded, it must be placed in Position 1 or Position 2. Position 3 is not a valid choice as that would 
mean Position 2 would have been skipped. The application will not allow the user to load maps 
into invalid slots. The user specifies the storage slot for the map by making a selection in the 
Choose Map Position dialog shown in Figure 15.  
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Figure 15  Choose Map Position window 

In Figure 15 LIBERTY has one map already stored in Position 1. The number of maps presently 
stored in LIBERTY is indicated by the text at the top of the dialog. Note that in this example, 
Position 3 is not a valid choice. 

When the user selects the OK button on this dialog the application begins loading the map into 
LIBERTY. A progress bar is displayed to indicate the loading progress, as shown in Figure 16. 
Loading typically takes less than five seconds. 

 
Figure 16  Successful loading of Map in position 2 

Upon successful loading, a message box similar to that in Figure 16 will be displayed.  

At this point a map has been successfully created and loaded by the MapCollect application. 
Compensation using this map can be started by sending LIBERTY a dn<return> command, 
where n is the position of the map (1-3, 0 turns compensation off), or by using the appropriate 
API function call. 

1.3.7 Live Sensor View 
Once a map has been loaded the user may select the Live Sensor View window to see the 
distortion correction being applied. This window will show the live position of each sensor on 
the pole. The vertical position will be relative to the highest sensor, the horizontal position will 
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be relative to the mapped area. The user may select to turn compensation off, or to change 
compensation from one map to another by selecting the appropriate choice. The user can invoke 
the Live Sensor View by selecting the View->Live Graphical Data menu item or the  toolbar 
item. Figure 17 is a sample screen shot of the Live Sensor View. This example represents an 
eight-sensor pole with the positive X direction toward the right side of the screen. All the sensors 
are in the mapped area since they all are solid colors. If any were out of the defined map box 
they would appear hatched, as the legend indicates. The user may rotate the view by 90 degrees 
to see the other horizontal axis by selecting the Rotate 90 degrees button. In any case where the 
floor is not the zero vertical position, the user may need to select the Flip Hemisphere button to 
see all sensors. 

 
Figure 17  Vertical Sensor View window 
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Since all filtering is turned off when map collection is started, this output could appear a little 
jumpy. This may be corrected by re-powering LIBERTY, which will re-establish the default 
filtering. 

 

 

2. DefineFrame Application   

2.1 Description 

The DefineFrame application is a utility that must be used to create a LIBERTY Mapping 
Definition (*.lmd) file. The *.lmd file is required when creating a custom LIBERTY distortion 
compensation map with the MapCollect application. These *.lmd files define a custom 
pole/sensor configuration, as well as the horizontal grid that the user desires to collect data 
during the map creation. The user is not required to create a *.lmd file if the Polhemus QWIK-
MAP mapping fixture will be used. However, if the user requires an area that is larger than that 
which the QWIK-MAP provides, a mapping fixture must be created that meets the user’s 
requirements. An example of a mapping pole can be seen in Figure 7. An *.lmd file must then be 
created using the DefineFrame application that defines the pole and the grid where the map data 
will be collected. By implementing this technique to define mapping regions, the user is allowed 
to create numerous pole and floor configurations depending on a location or situation, and then 
easily load the appropriate *.lmd file at map creation. This section provides the procedure for 
using the DefineFrame application to create the necessary *.lmd file. 

Creating a map with LIBERTY allows much more flexibility than previous tracking products. 
The mapping reference frame is defined by the user and the source location is absolutely 
arbitrary (of course, the source should be located within the operational range for all points in the 
map and away from any metal distorters). The user defines all three axes of the reference frame. 
These axes do not need to correspond to the source reference frame. The user must, however, 
define a frame that follows the right-hand rule. A way to test this is to point the index finger of 
your right hand along the desired reference frame X-axis with your palm facing the Y-axis; your 
thumb will point to the Z-axis, as in Figure 18. 

 
 Figure 18  The “Right Hand Rule” demonstrated 
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Another example of the right hand rule will help you to remember the positive and negative 
rotation directions, as shown in Figure 19. By wrapping your right hand around an axis in a 
reference frame that has been developed using the previously described right hand rule, the 
direction of positive rotation is indicated by the curl of the fingers. 

 
Figure 19  Using the Right-Hand Rule 

 

Other than this requirement, the user is free to set the axes of the mapping frame in any Cartesian 
configuration. Additionally, the user will define the position of the origin of the mapping frame. 
When the map is created and being used by the LIBERTY system, the position and orientation 
values output will be referenced to the user-defined mapping origin and frame axes. 

The DefineFrame application also may be used to edit existing *.lmd files. Both horizontal grid 
changes and changes to the sensors/pole configuration may be made, or the user may use an 
existing file as the basis for a new file to be created. 
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2.2 Procedure for creating a *.lmd file 

When the DefineFrame application is started, the window shown in Figure 20 will appear on the 
PC screen. Note that both the Pole Definition and the Floor Grid Definition are empty. 

 
Figure 20  DefineFrame Startup window 

First select the units that will be used in the definitions. The application will default to inches, 
but may be changed to centimeters by selecting that choice in the Units box located at the top 
right portion of the window. Angle measurements are always in degrees. 

2.3 Floor Grid Definition 

Next, a floor grid definition should be created. The floor grid is a collection of points located on 
the floor or stage/riser, relative to the user-defined origin and frame configuration, where the 
mapping pole will be placed during data collection. When the user selects the Create/Edit Grid 
Definition button the dialog box shown in Figure 21 will be displayed. This is where the floor 
points for collection will be identified. The user should first define the two horizontal axes (the 
floor axes) by selecting the appropriate choice from the Axis Definition box of the Define Floor 
Grid screen. From this dialog box the user may add floor collection points in two ways. The first 
way is to select a start point, increment, and number of points per axis, for each axis of the floor 
grid. Then select the Fill Grid Points button. This will generate all the points that correspond to 
start, increment, and number of points supplied for each axis. The second way to add points is to 
select the Add Points to Grid button. This will display the Add Floor Grid Point dialog box 
(Figure 22). From this dialog box the user may add any individual floor point to the grid. 
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Figure 21  Define Floor Grid window 

Finally, from the Define Floor Grid dialog the user may delete floor grid points. To delete a 
point the user can select the point from the list of points on the right, and select the Remove 
Selected Points button. Highlight and click on each point to select a group of points to be 
removed. This could be useful when editing an existing *.lmd file. 

 
Figure 22  Add Floor Grid Point window 

When the user selects the OK button, the Define Floor Grid dialog closes and the floor collection 
points are listed in the main application window. 

IMPORTANT 

The floor grid must be a minimum of four points along each axis.  
Fewer points than this can cause faulty maps. 
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2.4 Pole Definition 

After defining the floor/stage/riser grid, the mapping pole also must be defined. When the user 
selects the Create/Edit Pole Definition button the application will first query the user for the 
number of sensors attached to the pole, as shown in Figure 23. The user may select a value 
between two and 16. After the user selects the number of sensors on the pole, the Sensor Position 
and Orientation Data dialog box shown in Figure 24 will be displayed.  

 
Figure 23  Create/Edit Pole Definition: Number of Sensors window 

In Figure 24, notice that there is a tab for each group of four sensors. The user is required to 
provide the offset data for each sensor on the pole. The user should pay very close attention to 
the sign of each value, especially on the vertical axis (first column). These values may actually 
decrease as the distance from the floor increases (when the vertical axis is positive in the down 
direction).  

 
Figure 24  Sensor Position and Orientation Data window 

The vertical offsets are measured from the floor (or the zero position of the vertical axis if it is 
other than the floor). The horizontal offsets (second and third column) are measured from the 
center of the pole, so that when the pole is centered on the floor point, the actual sensor position 
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can be obtained by adding the floor point and the appropriate offset. This means that the offset 
may be a negative number. 

In addition to the offset data the user must also provide the orientation data for the sensors. Euler 
angles for azimuth, elevation, and roll should be entered in the appropriate spaces. All angles 
must be in degrees. Again, these orientation values are relative to the user-defined reference 
frame and have no correlation to the position of the source during mapping. 

When all offset and orientation data for each sensor on each tab has been entered and the user 
selects the OK button, the main window will be updated with the pole information. See the 
sample window in Figure 25. 

 
Figure 25  Main window updated after Sensors have been updated 

2.5 Saving *.lmd File 

The final step is to save the *.lmd file with the data just provided for the floor grid and the pole 
definitions. When the user selects the Save to File button, a Save As window will appear that will 
allow the user to save the *.lmd file at the desired location, as shown in Figure 26. 

Rev. C 20 FEBRUARY 2008 



  LIBERTY MAPPING TOOLKIT 

 
Figure 26  Save As window to create *.lmd file 

2.6 Editing Previous Files 

Previously defined *.lmd files may be loaded into the DefineFrame application for editing by 
selecting the Open Existing Definition File button. This will load the floor grid and pole 
definitions so that the user may edit these definitions and either change the existing file or save 
them as a new file. 

Following the above procedure will create a binary *.lmd file that can be read by the MapCollect 
application which will be used to create the compensation map used by LIBERTY trackers. 
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3. MapCollect Application  

3.1 Description 

The MapCollect application is a Windows-based host application that provides a Polhemus 
LIBERTY user with the ability to create and load distortion compensation maps into the 
LIBERTY system. LIBERTY is capable of holding three different compensation maps to allow 
for the flexibility of using the same LIBERTY in different or changing environments. Maps may 
be stored in LIBERTY, on a host PC as a LIBERTY Map File (*.lmf), or both. The MapCollect 
application is used to create or load maps taken either with the Polhemus QWIK-MAP or as a 
customer-defined map volume. This application is to be used with a vertical configuration of two 
to 16 sensors. The Polhemus QWIK-MAP must be used with four sensors. This vertical bank of 
sensors is to be moved to various grid points on a floor, the QWIK-MAP, or some other 
horizontal plane defined by the user. At each grid point data are collected for all sensors to create 
a “cube” which will make up the map volume. The grid points need not be symmetrical; some 
may be two inches apart where others may be 12 inches apart. It all depends on the distortion and 
how dense a map the user desires. The QWIK-MAP defines a grid with symmetric points 
approximately six inches apart. 

The user must use the MapCollect Application to collect all the data in the map volume. The 
application then can be used to create a LIBERTY compensation map. This map will be created 
in the form of a *.lmf file. The application provides the user with a direct interface into 
LIBERTY to load and store the created map. Additionally, the application provides the user with 
the ability to erase ALL maps stored in the LIBERTY system. Graphical and textual interfaces 
are used to show mapping progress and to lead the user through the necessary steps.  

The MapCollect application main window is divided into two sub-windows. One is a graphical 
representation of the horizontal or floor grid to be used for the mapping operation. As points are 
collected along this grid the icons representing the points will change to reflect the new status. 
The user can see the collection progress at a glance or which point to move to next. This window 
also provides the user with a means for retaking points or changing the selected point with the 
click of the mouse. This window is not visible on startup. It will become visible when either the 
QWIK-MAP option is selected, or a LIBERTY Map Definition file (*.lmd) is loaded. The 
second window is a text-based, scrollable window which records all actions in real time. It will 
record the data for each point as it is collected, as well as the defined position of that point. This 
view is always visible at the bottom of the screen, and may be copied to file or printed. Either 
window may be enlarged or reduced to see more data.  

An additional window may be invoked which will show the sensors’ position in real time relative 
to the map and each other. The scale of the window is the size of the map. This view allows the 
user to change the current map or turn off compensation. It also provides the user with a visual 
representation of how well the map is correcting in the user’s specific environment. 

If the user is not employing the Polhemus QWIK-MAP with the MapCollect application, he/she 
must supply a custom *.lmd file that was generated using the DefineFrame utility supplied with 
this application. This will define the floor grid orientation and the map area origin. The 
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coordinate system of the mapped area is completely user-defined. It is defined either by the 
*.lmd file or the QWIK-MAP fixture. The source location and orientation is completely 
irrelevant other than that it must be within the specified distance to all points in the mapped area. 
If using the QWIK-MAP, the coordinate axes will be defined by the user before data collection 
begins. All axes must be defined such that the coordinate system is a right-hand system; see 
Figure 18. 

3.2 MapCollect Interface 

Following is a description of the user-interface items and controls of the application. 

3.2.1 Menus 

3.2.1.1 File 
 Set Definition File Used to identify the *.lmd file to be used to define the horizontal 

grid and sensor configuration. Only used if the Polhemus QWIK-
MAP is not being used. 

 Use Polhemus  

 QWIK-MAP Definitions Used to notify the application that the QWIK-MAP is being used. 

 Clear Screen Clears the Main Text View window of the application. 

 Save Screen to File Saves the Main Text View window of the application to a file 
specified by the user. 

 Print Screen Prints the Main Text View window. 

 Exit Terminates the program. Any data collected in which a map has 
not yet been created will not be saved. 

3.2.1.2 Collection 
 Set COM Port Allows the user to indicate which port to connect with when using 

RS232 communications. 

 Set Hemisphere Allows the user to force a hemisphere of operation. 

 High Distortion Mode    Available with a “distortion mitigation technology” source only.  
Provides better compensation in areas of very high distortion, but 
may result in excessive noise in less distorted areas. 

 Low Distortion Mode    Provides a less noisy solution when the mapped area is not heavily 
distorted. 

 Collect Data Puts the application into Data Collect Mode. This will establish 
communications with LIBERTY over either RS232 or USB. The 
Data Collection toolbar will become visible in this mode. 
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 Take Point Collects data for all sensors and assigns the data to the currently 
selected grid point. 

 Clear Point This will clear the data for the selected point. To be used if data are 
incorrectly taken at the wrong grid point. 

 Clear All Points This will clear the data associated with all the grid points. This 
would be used only if the user decides to start over. 

 Quit Collection Takes the application out of Data Collection Mode. This will 
terminate the connection with LIBERTY and hide the Data 
Collection Toolbar. The user can return to the same collection 
point if he/she returns to Data Collection Mode before re-loading a 
*.lmd file. 

3.2.1.3 Data 
 Create Map Selecting this will create a LIBERTY Map in the form of a *.lmf 

file using the data that was most recently collected. This will not 
be enabled until data for each grid point has been collected. 

 Load Map This menu item will load any map created with this application 
(*.lmf file) into a LIBERTY system. 

 Erase All Maps This will erase all the maps stored in the LIBERTY system. Be 
careful with this one. Once erased, maps must be reloaded to be 
used again. 

3.2.1.4 View 
 Toolbar Allows the user to show or hide the toolbar. 

 Status Bar Allows the user to show or hide the status bar. 

 Live Graphical Data Invokes a new window that shows a live graphical view of the 
sensors. Sensors are represented by different colored balls that are 
solid if they are in the mapped area, and hatched if they are not (or 
if compensation is turned off). 

3.2.1.5 Help 
 About MapCollect Displays the version number of the application. 

3.2.2 Toolbars 

3.2.2.1 Main Toolbar 
  Same as File->Clear Screen menu item 

  Same as File->Save Screen to File menu item 

  Same as File->Print Screen menu item 

Rev. C 24 FEBRUARY 2008 



  LIBERTY MAPPING TOOLKIT 

  Same as File->Use Polhemus QWIK-MAP menu item 

  Same as File->Set Definition File menu item 

  Same as Collection->Collect Data menu item 

  Same as View->Live Graphical Data menu item 

  Same as Data->Create Map menu item 

  Same as Data->Load Map menu item 

  Same as Data->Erase All Maps menu item 

  Same as Help->About MapCollect menu item 

3.2.2.2 Data Collection Toolbar 
  Same as Collection->Take Point menu item 

  Same as Collection->Clear Point menu item 

  Same as Collection->Clear All Points menu item 

  Same as Collection->Quit Collection menu item 

3.2.3 Main Text View 
The Main Text View is a window that records the actions that have been taken during the 
mapping operation. It will record the data collected from LIBERTY during collection, the *.lmd 
file being used, and various other actions that have occurred. The text from this window may be 
saved to a file or printed at the user’s discretion by selecting the appropriate menu/toolbar items. 
Figure 27 is a sample of the main text window. 
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Figure 27  Sample Main Text View window 

3.2.4 Grid View 
The Grid View is a window that depicts the grid points of the map and shows the user the status 
of the collected points. The axes are labeled by arrows at the lower left corner of the grid. Note 
that the vertical axis is designated by  to be positive in the down direction and by  to be 
positive in the up direction. These labels will change depending on the *.lmd file definitions or 
the QWIK-MAP axes designations. 

3.2.4.1  QWIK-MAP View 
If the QWIK-MAP fixture is being used, each point is represented by an arrowhead. Each point 
is numbered corresponding to the numbers on the QWIK-MAP fixture. A gray arrowhead 
indicates an uncollected point, blue indicates a collected point, and a red arrowhead designates 
the currently selected point. A sample of this view is shown in Figure 28. The first two points 
have been collected and the user is instructed to move the pole to position 3. Notice the Data 
Collection toolbar is floating in the Grid View Window, and the Main Text View Window is at 
the bottom of the main window. 

 
Figure 28  MapCollect Application during collection using QWIK-MAP 
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3.2.4.2 Custom Map View 
If a custom map is being collected, each floor point is represented by an ellipse if the point has 
not been collected, and an ‘X’ if the point has been collected. The current selected point will 
always be red (see Figure 29). In this example, the grid points located at 0,0 and 0,12 have been 
collected. The currently selected point is 0,24. The text under the grid instructs the user to which 
point to move the pole for the next grid point. Again, notice the Data Collection toolbar is 
floating in the Grid View Window, and the Main Text View Window at the bottom of the main 
window.  

 
Figure 29  MapCollect Application during collection of custom map 

3.2.5 Status Bar 
As illustrated in the above screen shots, the status bar indicates whether the application is in 
Normal or Collection Mode. In Collection Mode the status bar will indicate the point that is 
currently selected, either by coordinate if using a custom *.lmd, or by point number if using the 
QWIK-MAP. 
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